The goal of BiometryTraining is to provide functions to aid in the Design and Analysis of Agronomic-style experiments through easy access to documentation and helper functions, especially while teaching these concepts.

Installation

Use the following code to install this package:

if(!require("remotes")) install.packages("remotes") 
remotes::install_github("biometryhub/BiometryTraining", upgrade = FALSE)

Using the package

Load the package and start using it with:

If you find this pacakge useful, please cite it! Type citation("BiometryTraining") on the R console to find out how.

Troubleshooting Installation

  • If you have the latest version already installed, you will get a response like:

Skipping install of ‘BiometryTraining’ from a github remote, the SHA1 (e034b603) has not changed since last install.
Use force = TRUE to force installation

  • The following warning messages can usually be ignored:

WARNING: Rtools is required to build R packages, but is not currently installed.

Please download and install Rtools custom from https://cran.r-project.org/bin/windows/Rtools/.

Warning messages:
1: In untar2(tarfile, files, list, exdir) :
skipping pax global extended headers
2: In untar2(tarfile, files, list, exdir) :
skipping pax global extended headers

  • If you receive an error that the package could not install because rlang or another package could not be upgraded, the easiest way to deal with this is to uninstall the package(s) that could not be updated (remove.packages("rlang")). Then reinstall with install.packages("rlang") and then try installing BiometryTraining again.